summaryrefslogtreecommitdiffstats
path: root/module/setup.py
diff options
context:
space:
mode:
authorGravatar RaNaN <Mast3rRaNaN@hotmail.de> 2011-02-18 22:33:06 +0100
committerGravatar RaNaN <Mast3rRaNaN@hotmail.de> 2011-02-18 22:33:06 +0100
commitd79c1b3a6d1a6481b77598edf71fcb53eb6bb655 (patch)
tree04746ec4511a4d3e134a3781cb7e68dc3974411c /module/setup.py
parentyoutube fix, xdccrequest abort dl implemented (diff)
downloadpyload-d79c1b3a6d1a6481b77598edf71fcb53eb6bb655.tar.xz
closed #242, #243, #244
Diffstat (limited to 'module/setup.py')
-rw-r--r--module/setup.py19
1 files changed, 16 insertions, 3 deletions
diff --git a/module/setup.py b/module/setup.py
index f7b5839e0..39352d6d3 100644
--- a/module/setup.py
+++ b/module/setup.py
@@ -20,14 +20,11 @@ from getpass import getpass
import gettext
from hashlib import sha1
import os
-from os import remove
from os import makedirs
from os.path import abspath
from os.path import dirname
from os.path import exists
-from os.path import isfile
from os.path import join
-import random
import re
from subprocess import PIPE
from subprocess import call
@@ -51,6 +48,22 @@ class Setup():
translation.install(True)
print ""
+ print _("Would you like to configure pyLoad via Webinterface?")
+ print _("You need a Browser and a connection to this PC for it.")
+ viaweb = self.ask(_("Start initial webinterface for configuration?"), "y", bool=True)
+ if viaweb:
+ try:
+ from module.web import ServerThread
+ ServerThread.setup = self
+ from module.web import webinterface
+ webinterface.run_simple()
+ return False
+ except Exception, e:
+ print "Setup failed with this error: ", e
+ print "Falling back to commandline setup."
+
+
+ print ""
print _("Welcome to the pyLoad Configuration Assistent.")
print _("It will check your system and make a basic setup in order to run pyLoad.")
print ""