summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py63
1 files changed, 63 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000..21664ccc8
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,63 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+
+import sys
+from os import path
+
+from setuptools import setup
+
+PROJECT_DIR = path.abspath(path.dirname(__file__))
+
+extradeps = []
+if sys.version_info <= (2, 5):
+ extradeps += 'simplejson'
+
+from pyload import __version__
+
+setup(
+ name="pyload",
+ version=__version__,
+ description='Fast, lightweight and full featured download manager.',
+ long_description=open(path.join(PROJECT_DIR, "README.md")).read(),
+ keywords=('pyload', 'download-manager', 'one-click-hoster', 'download'),
+ url="http://pyload.org",
+ download_url='http://pyload.org/download',
+ license='AGPL v3',
+ author="pyLoad Team",
+ author_email="support@pyload.org",
+ platforms=('Any',),
+ #package_dir={'pyload': 'src'},
+ packages=['pyload'],
+ #package_data=find_package_data(),
+ #data_files=[],
+ include_package_data=True,
+ exclude_package_data={'pyload': ['docs*', 'scripts*', 'tests*']}, #exluced from build but not from sdist
+ # 'bottle >= 0.10.0' not in list, because its small and contain little modifications
+ install_requires=['pycurl', 'Beaker >= 1.6'] + extradeps,
+ extras_require={
+ 'SSL': ["pyOpenSSL"],
+ 'DLC': ['pycrypto'],
+ 'Lightweight webserver': ['bjoern'],
+ 'RSS plugins': ['feedparser'],
+ 'Few Hoster plugins': ['BeautifulSoup>=3.2, <3.3']
+ },
+ #setup_requires=["setuptools_hg"],
+ test_suite='nose.collector',
+ tests_require=['nose', 'websocket-client >= 0.8.0', 'requests >= 1.2.2'],
+ entry_points={
+ 'console_scripts': [
+ 'pyload = pyload.Core:main',
+ 'pyload-cli = pyload.cli.Cli:main'
+ ]},
+ zip_safe=False,
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Topic :: Internet :: WWW/HTTP",
+ "Environment :: Console",
+ "Environment :: Web Environment",
+ "Intended Audience :: End Users/Desktop",
+ "License :: OSI Approved :: GNU Affero General Public License v3",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python :: 2"
+ ]
+) \ No newline at end of file