summaryrefslogtreecommitdiffstats
path: root/module/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'module/setup.py')
-rw-r--r--module/setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/module/setup.py b/module/setup.py
index 645089a55..21bf5341d 100644
--- a/module/setup.py
+++ b/module/setup.py
@@ -418,7 +418,7 @@ class Setup():
else:
qst = _("Password: ")
- p1 = getpass(qst)
+ p1 = getpass(qst.encode("utf-8"))
if len(p1) < 4:
print _("Password to short. Use at least 4 symbols.")
@@ -429,7 +429,7 @@ class Setup():
else:
qst = _("Password (again): ")
- p2 = getpass(qst)
+ p2 = getpass(qst.encode("utf-8"))
if p1 == p2:
return p1