summaryrefslogtreecommitdiffstats
path: root/module/setup.py
diff options
context:
space:
mode:
authorGravatar Walter Purcaro <vuolter@gmail.com> 2014-06-28 14:49:34 +0200
committerGravatar Walter Purcaro <vuolter@gmail.com> 2014-06-28 20:21:03 +0200
commit6abc3221c9b5ba1a1b54633c8283c7c5c978558a (patch)
treeb98bb58c4e10bc6638cebfc2fb1327ca71adb797 /module/setup.py
parentUpdate CherryPy wsgiserver to version 3.2.1 (diff)
downloadpyload-6abc3221c9b5ba1a1b54633c8283c7c5c978558a.tar.xz
[GUI] Removed
Diffstat (limited to 'module/setup.py')
-rw-r--r--module/setup.py31
1 files changed, 13 insertions, 18 deletions
diff --git a/module/setup.py b/module/setup.py
index 0127b629a..937ca5395 100644
--- a/module/setup.py
+++ b/module/setup.py
@@ -63,7 +63,7 @@ class Setup():
print _("When you are ready for system check, hit enter.")
raw_input()
- basic, ssl, captcha, gui, web, js = self.system_check()
+ basic, ssl, captcha, web, js = self.system_check()
print ""
if not basic:
@@ -79,12 +79,16 @@ class Setup():
print ""
avail = []
- if self.check_module("Crypto"): avail.append(_("container decrypting"))
- if ssl: avail.append(_("ssl connection"))
- if captcha: avail.append(_("automatic captcha decryption"))
- if gui: avail.append(_("GUI"))
- if web: avail.append(_("Webinterface"))
- if js: avail.append(_("extended Click'N'Load"))
+ if self.check_module("Crypto"):
+ avail.append(_("container decrypting"))
+ if ssl:
+ avail.append(_("ssl connection"))
+ if captcha:
+ avail.append(_("automatic captcha decryption"))
+ if web:
+ avail.append(_("Webinterface"))
+ if js:
+ avail.append(_("extended Click'N'Load"))
string = ""
@@ -114,11 +118,6 @@ class Setup():
print _("Only needed for some hosters and as freeuser.")
print ""
- if not gui:
- print _("Gui not available")
- print _("The Graphical User Interface.")
- print ""
-
if not js:
print _("no JavaScript engine found")
print _("You will need this for some Click'N'Load links. Install Spidermonkey, ossp-js, pyv8 or rhino")
@@ -214,10 +213,6 @@ class Setup():
print ""
- gui = self.check_module("PyQt4")
- self.print_dep("PyQt4", gui)
-
- print ""
jinja = True
try:
@@ -247,7 +242,7 @@ class Setup():
js = True if JsEngine.ENGINE else False
self.print_dep(_("JS engine"), js)
- return basic, ssl, captcha, gui, web, js
+ return basic, ssl, captcha, web, js
def conf_basic(self):
@@ -255,7 +250,7 @@ class Setup():
print _("## Basic Setup ##")
print ""
- print _("The following logindata is valid for CLI, GUI and webinterface.")
+ print _("The following logindata is valid for CLI and webinterface.")
from module.database import DatabaseBackend