summaryrefslogtreecommitdiffstats
path: root/module/setup.py
diff options
context:
space:
mode:
authorGravatar mkaay <mkaay@mkaay.de> 2010-09-06 21:59:15 +0200
committerGravatar mkaay <mkaay@mkaay.de> 2010-09-06 21:59:15 +0200
commit4c0ee663697e796a8cdb80cd232e3a637be2efaf (patch)
tree7e6d324793364e59f73f2ee0d5ce43deb1b75c1e /module/setup.py
parentrecheck fix, account update fix (diff)
downloadpyload-4c0ee663697e796a8cdb80cd232e3a637be2efaf.tar.xz
getpass locale fix
Diffstat (limited to 'module/setup.py')
-rw-r--r--module/setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/module/setup.py b/module/setup.py
index 645089a55..21bf5341d 100644
--- a/module/setup.py
+++ b/module/setup.py
@@ -418,7 +418,7 @@ class Setup():
else:
qst = _("Password: ")
- p1 = getpass(qst)
+ p1 = getpass(qst.encode("utf-8"))
if len(p1) < 4:
print _("Password to short. Use at least 4 symbols.")
@@ -429,7 +429,7 @@ class Setup():
else:
qst = _("Password (again): ")
- p2 = getpass(qst)
+ p2 = getpass(qst.encode("utf-8"))
if p1 == p2:
return p1