summaryrefslogtreecommitdiffstats
path: root/module/setup.py
diff options
context:
space:
mode:
authorGravatar RaNaN <Mast3rRaNaN@hotmail.de> 2011-11-19 22:44:24 +0100
committerGravatar RaNaN <Mast3rRaNaN@hotmail.de> 2011-11-19 22:44:24 +0100
commit3b9885e40961bde996014c7e82d59daf2bd7ac14 (patch)
tree54f60f42b9b445d8b497d373a9d16eefd262ce87 /module/setup.py
parentcatch real debrid error, when ip is blocked (diff)
downloadpyload-3b9885e40961bde996014c7e82d59daf2bd7ac14.tar.xz
disableble thriftbackend
Diffstat (limited to 'module/setup.py')
-rw-r--r--module/setup.py20
1 files changed, 14 insertions, 6 deletions
diff --git a/module/setup.py b/module/setup.py
index 8677fb65a..4a1c59da6 100644
--- a/module/setup.py
+++ b/module/setup.py
@@ -238,12 +238,14 @@ class Setup():
try:
import jinja2
- if jinja2.__version__ and "unknown" not in jinja2.__version__ and not jinja2.__version__.startswith("2.5"): #@TODO: could be to new aswell
- print _("Your installed jinja2 version %s seems too old.") % jinja2.__version__
- print _("You can safely continue but if the webinterface is not working,")
- print _("please upgrade or deinstall it, pyLoad includes a sufficient jinja2 libary.")
- print
- jinja = False
+ v = jinja2.__version__
+ if v and "unknown" not in v:
+ if not v.startswith("2.5") and not v.startswith("2.6"):
+ print _("Your installed jinja2 version %s seems too old.") % jinja2.__version__
+ print _("You can safely continue but if the webinterface is not working,")
+ print _("please upgrade or deinstall it, pyLoad includes a sufficient jinja2 libary.")
+ print
+ jinja = False
except :
pass
@@ -278,6 +280,12 @@ class Setup():
db.shutdown()
print ""
+ print _("External clients (GUI, CLI or other) need remote access to work over the network.")
+ print _("However, if you only want to use the webinterface you may disable it to save ram.")
+ self.config["remote"]["activated"] = self.ask(_("Enable remote access"), "y", bool=True)
+
+
+ print ""
langs = self.config.getMetaData("general", "language")
self.config["general"]["language"] = self.ask(_("Language"), "en", langs["type"].split(";"))