summaryrefslogtreecommitdiffstats
path: root/module/setup.py
diff options
context:
space:
mode:
authorGravatar RaNaN <Mast3rRaNaN@hotmail.de> 2012-01-12 20:34:33 +0100
committerGravatar RaNaN <Mast3rRaNaN@hotmail.de> 2012-01-12 20:34:33 +0100
commit8b94229290b5cb9beedd318af8499c44624b3ad0 (patch)
treec21229e4a9e617cc7423daf191411086f6c41d45 /module/setup.py
parentpyflakes fix (diff)
downloadpyload-8b94229290b5cb9beedd318af8499c44624b3ad0.tar.xz
added setup.py, dropped GUI
Diffstat (limited to 'module/setup.py')
-rw-r--r--module/setup.py14
1 files changed, 2 insertions, 12 deletions
diff --git a/module/setup.py b/module/setup.py
index e3fb07344..d16b8c9e2 100644
--- a/module/setup.py
+++ b/module/setup.py
@@ -82,7 +82,7 @@ class Setup():
print _("When you are ready for system check, hit enter.")
raw_input()
- basic, ssl, captcha, gui, web, js = self.system_check()
+ basic, ssl, captcha, web, js = self.system_check()
print ""
if not basic:
@@ -101,7 +101,6 @@ class Setup():
if self.check_module("Crypto"): avail.append(_("container decrypting"))
if ssl: avail.append(_("ssl connection"))
if captcha: avail.append(_("automatic captcha decryption"))
- if gui: avail.append(_("GUI"))
if web: avail.append(_("Webinterface"))
if js: avail.append(_("extended Click'N'Load"))
@@ -133,11 +132,6 @@ class Setup():
print _("Only needed for some hosters and as freeuser.")
print ""
- if not gui:
- print _("Gui not available")
- print _("The Graphical User Interface.")
- print ""
-
if not js:
print _("no JavaScript engine found")
print _("You will need this for some Click'N'Load links. Install Spidermonkey, ossp-js, pyv8 or rhino")
@@ -232,10 +226,6 @@ class Setup():
print ""
- gui = self.check_module("PyQt4")
- self.print_dep("PyQt4", gui)
-
- print ""
jinja = True
try:
@@ -263,7 +253,7 @@ class Setup():
js = True if JsEngine.ENGINE else False
self.print_dep(_("JS engine"), js)
- return basic, ssl, captcha, gui, web, js
+ return basic, ssl, captcha, web, js
def conf_basic(self):
print ""