summaryrefslogtreecommitdiffstats
path: root/module/setup.py
diff options
context:
space:
mode:
authorGravatar RaNaN <Mast3rRaNaN@hotmail.de> 2010-08-15 14:43:18 +0200
committerGravatar RaNaN <Mast3rRaNaN@hotmail.de> 2010-08-15 14:43:18 +0200
commit03eecc372628391815f9b0091a0bd980c146685d (patch)
tree7c3ccb195668905cae8a668f8d90eb19bc8f8ea6 /module/setup.py
parentfix (diff)
downloadpyload-03eecc372628391815f9b0091a0bd980c146685d.tar.xz
some fixes, fixed #125
Diffstat (limited to 'module/setup.py')
-rw-r--r--module/setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/module/setup.py b/module/setup.py
index ac2bb57c2..95533e698 100644
--- a/module/setup.py
+++ b/module/setup.py
@@ -270,10 +270,10 @@ class Setup():
print ""
- call(["python", join(self.path, "module", "web", "manage.py"), "syncdb", "--noinput"])
+ call(["python", join(self.path, "module", "web", "manage.py"), "syncdb", "--noinput", "--settings=module.web.settings"])
print _("If you see no errors, your db should be fine and we're adding an user now.")
username = self.ask(_("Username"), "User")
- call(['python', join(self.path, "module", "web", "manage.py"), 'createsuperuser', '--email=email@trash-mail.com', '--username=%s' % username, '--noinput'])
+ call(['python', join(self.path, "module", "web", "manage.py"), 'createsuperuser', '--email=email@trash-mail.com', '--username=%s' % username, '--noinput', "--settings=module.web.settings"])
password = self.ask("", "", password=True)
salt = reduce(lambda x, y: x + y, [str(random.randint(0, 9)) for i in range(0, 5)])